Solution applies to: < IMMS: M3/M6/VLX >
Problem description
In old UI: UI switches on , when you click on the record dataset- It shows an error message like this:
[13:28:38] Failed to prepare mapping:
[Errno 13] Permission denied: '/srv/data'
In new UI: It warns even before you can start the UI:
Could not find a usable SSD
Root cause
1) SSD is not mounted and not setup
2) SSD is mounted but not setup
3) SSD is setup but not mounted
3) If above options are not true then SSD might be corrupted
Solutions
1) SSD mount spot is occupied.
Disconnect the SSD and see if there is still a \srv folder available. If yes you can delete it with following command: sudo rm -rf \srv
Afterwards connect the SSD again to mount it.
2) To check if it's mounted, you could open the "Disks" application from the system, and search for the external SSD disk.
If it's not mounted, it will show "Not Mounted" in the "Contents" field. Also the Volume will have an icon like a "Play" button.
Press the "Play" button to mount it.
3) If the SSD is mounted but not setup, or if the SSD itself is corrupted, please refer to our documentations how to set up the disk in correct formats and folder structures.
Please make sure that your SSD is named / labeled as "data" and not like "DATA".
Please considering following our documentation on formatting the disk to exfat, so it can be recognised across different operating systems. For detailed explanation click here: MIGRATING AN EXTERNAL SSD TO EXFAT
4) [M6] If you have first booted up the device and then inserted the SSD, it can happen that it is not recognized. Simply try restarting the M6 with the SSD inserted.
5) [VLX] If the SSD is not found in the Disks application in Ubuntu then it can happen that the customer has not plugged the SSD well into the SSD slot on the VLX. You can try to connect the SSD via cable to the USB slot in the VLX and check if the SSD is operational. Also, the T5 SSD shipped with the VLX should stick out exactly 30mm from the device. Tell the customer to measure it and if it is even a few mm over 30 then it is not inserted well. Let the customer move the SSD around until fully inserted.
If the SSD was never used in a VLX before, open a terminal and run navvis-mapping-ui which should open the Mapping UI and set up the needed folders on the SSD. Rename the SSD via the Disk utility to "data" in order to be successfully recognised by your VLX.